欢迎光临
一直在路上

解决debian系安装Nginx时需要先安装依赖包出错问题

安装Nginx时需要先安装依赖包,Ubuntu中不像centOS等使用yum直接在线安装,在网上找了好多方法,最后发现以下方法好用:(ubuntu请自行加sudo)

首先使用dpkg命令查看自己需要的软件是否安装。

例如查看zlib是否安装:

dpkg -l | grep zlib  

解决依赖包openssl安装,命令:

apt-get install openssl libssl-dev  

解决依赖包pcre安装,命令:

apt-get install libpcre3 libpcre3-dev 

解决依赖包zlib安装,命令:

apt-get install zlib1g-dev  
赞(0)
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权
文章名称:《解决debian系安装Nginx时需要先安装依赖包出错问题》
文章链接:http://blog.moxiaonai.cn/noname/nginx-deppackages.html
本站资源仅供个人学习交流,请于下载后24小时内删除,不允许用于商业用途,否则法律问题自行承担。
个别资源收集于互联网,如有侵权,请联系博主删除。
分享到: 更多 (0)

评论 抢沙发

评论前必须登录!