解决debian系安装Nginx时需要先安装依赖包出错问题

安装Nginx时需要先安装依赖包,Ubuntu中不像centOS等使用yum直接在线安装,在网上找了好多方法,最后发现以下方法好用:(ubuntu请自行加sudo)

首先使用dpkg命令查看自己需要的软件是否安装。

例如查看zlib是否安装:

dpkg -l | grep zlib  

解决依赖包openssl安装,命令:

apt-get install openssl libssl-dev  

解决依赖包pcre安装,命令:

apt-get install libpcre3 libpcre3-dev 

解决依赖包zlib安装,命令:

apt-get install zlib1g-dev  

未经允许不得转载:莫小奈博客 » 解决debian系安装Nginx时需要先安装依赖包出错问题